Агент передачи файлов TCPFoss. Документация

Структура документации:

  • Введение
  • История версий
  • Установка программы
  • Настройка программы
  • Настройка операционной системы
  • Запуск и работа с программой


Введение

TCPFOSS Документация
Введение

Коммуникационная программа TCPFoss предназначена для передачи файлов в локальных и глобальных вычислительных сетях по протоколу TCP/IP. Передача ведется в автоматическом режиме.

Преимущества данной программы перед другими коммуникационными программами заключаются в следующем:

  • Обмен ведется в дуплексном режиме.
  • Допередача файлов при разрыве канала связи.
  • Передаваемые файлы могут иметь разные приоритеты. Появление более приоритетного файла вызывает приостановку передачи менее приоритетного файла. Это свойство позволяет отправлять низкоприоритетные файлы любого размера, задержки в отправке высокоприоритетных файлов не будет.
  • Оригинальный протокол обмена файлами значительно повышающий скорость обмена при передаче большого количества файлов малой длины. Например, при работе по выделенной линии связи при передаче файлов длиной менее 1 Кбайт TCPFoss превосходит PROCARRY по скорости в 2,5 раза, FTP-более, чем в 3 раза. При работе через спутниковые каналы связи и сеть X.25 эти цифры еще выше. При передаче длинных файлов скорость обмена близка к физической скорости канала связи.
  • Система защиты от несанкционированного доступа, базирующаяся на двух ключевом алгоритме шифрования RSA.
  • Передача файлов с длинными именами.
  • Возможность использования Internet как канал передачи данных.
  • Предоставляется возможность разделения каналов связи между различными приложениями, как-то: работа с SQL-запросами, WEB-серверами и т.д.
  • Маршрутизация пакетов средствами операционных систем, что позволяет не прерывать работу в случае отключения прямых каналов связи при существовании обходных.
  • Простота интеграции с почтовыми системами, использующими внешние коммуникационные программы.


История версий

История версий

Новые версии программы можно получить на сервере www.foss.kharkov.ua.

С автором программы можно связаться по адресу S.Mamontov@foss.kharkov.ua или mmm@foss.kharkov.ua.


V

V4.6.6
  • Исправлена ошибка в работе таймера #Break, появившаяся в V4.6.2.


V

V4.6.5
  • Аналогична V4.6.4.


V

V4.6.4
  • Добавлен параметр #Bind.


V

V4.6.3
  • Устранен повторный выход на связь перед автоматическим завершением клиентской версии.


V

V4.6.2
  • Вызов абонента считается удачным только после аутенификации, а не после установки tcp соединения. Это нужно для корректной работы таймера #Break при работе через прокси сервер.


V

V4.6.1
  • Можно задавать значения по умолчанию для параметров #RasPhone и #RasCon.
  • Устранено появление сообщения "Переполнение выходного буфера".
  • После закрытия окна с подробной информацией, иформация в нем не теряется.
  • Файл отчета об ошибке (.rpt) автоматически обнуляется.


V

V4.6.0
  • Внимание!!! Произошла смена серийных номеров.
  • В параметре #Pri, помимо маски файла, можно указывать подкаталог.
  • Добавлен параметр #InpPri.


V

V4.5.18
  • Устранена ошибка, которая могла приводить к тому, что в главном окне, для одного и того же абонента, отображалось две записи.


V

V4.5.17
  • Возвращена блокировка запуска второй копии программы под Windows XP и ниже.
  • У клиентской версии Tcpfoss расширено окно состояния абонента. Полоса прокрутки не должна налезать на информацию о текущем состоянии обмена.


V

V4.5.16
  • Значение параметра #Break может быть меньше 0.
  • Внесены изменения в работе по расписанию.


V

V4.5.15
  • Для снижения потребления ресурсов Windows внесены исправления в отображении окна с подробной информацией.
  • Добавлен параметр #CheckTime.
  • Исправлена ошибка, внесенная в версии 4.5.11, из-за которой TcpFoss переставал передавать файлы, если Windows не перегружалась более 25 дней.
  • Добавлены обработчики ошибок в COM сервер.


V

V4.5.14
  • Исправлена ошибка, из за которой не перебирались IP адреса, если в параметре #ConnectTimeOut на установку соединения задавался короткий интервал времени.
  • Формат help файла изменен на html для работ под Vista.
  • Параметром #NbuWarning нельзя задать срок менее 7 дней.


V

V4.5.13
  • Перебор альтернативных IP адресов делается при любой ошибке соединения.
  • Внесены изменения для получения статуса "Certified for Windows Vista".


V

V4.5.12
  • В лог файл работы библиотеки защиты НБУ пишется версия своей библиотеки и библиотеки на удаленной стороне.


V

V4.5.11
  • Если при проверке лог файла работы библиотеки НБУ возникла ошибка, создается новый файл, а старый переименовывается. В новый файл прописывается соответствующая запись.
  • Начиная с V19 версии библиотеки НБУ, предупреждение о истечении срока действия ключей задается параметром #NbuWarning.
  • Устранено аварийное завершение TCPFoss, если имя лог файла работы библиотеки НБУ содержит символ %.
  • Исправлена ошибка в переборе IP адресов, из-за которой на Windows Server могло появляться сообщение "Неизвестный абонент".
  • При вызове абонента отображается его адрес.
  • В окне с подробной информацией, обновление данных происходит не чаще раза в секунду, чтобы снизить нагрузку на процессор.
  • При появлении незапланированных исключений, окно с сообщением об ошибке появляется в начале создания отчета об ошибке.


V

V4.5.10
  • В клиентской версии исправлена проблема с вычислением размера окна, при запуске в свернутом состоянии.
  • Добавлена возможность управлять отображением окна TCPFoss при работе в качестве транспорта Outlook.
  • Если параметр #Scan = 0, программа не выгружается, пока не произойдет обмен, как и было до версии 4.5.8.
  • Исправлена ошибка с приостановкой передачи файлов с низким приоритетом.


V

V4.5.9
  • В лог-файле отображается полная версия абонента.
  • Добавлен параметр #BeepErr.
  • В главном окне программы отображается причина, по которой не удалось связаться с абонентом.
  • В главном окне программы отображается дата и время смены состояния, раньше, только время.
  • Исправлена ошибка, из-за которой не передавались файлы с низким приоритетом, если у файлов с маской *.* был более высокий приоритет.
  • В журнале НБУ пишется информация о запросе срока действия ключа.
  • Изменен диалог с выдачей предупреждения об окончании срока действия ключа.
  • Вторая копия программы теперь не запускается, даже когда первая копия свернута в трей.
  • Исправлена ошибка, которая при завершении программы могла приводить к возникновению незапланированного исключения. Ошибка возникала, если в имени файла задан метасимвол %N.


V

V4.5.8
  • Добавлен обработчик незапланированных исключений. При их появлении создается отчет об ошибке, и серверная версия программы перезапускается.
  • При работе по расписанию, в моменты, когда #Scan=-1, вызов абонента прекращается. Раньше, вызов прекращался после успешного обмена.
  • Добавлены параметры #LanAddr, #RasAddr, #RasAddr для перебора IP адресов.
  • На базе TCPFoss сделана программа IpxFoss для обмена в сети IPX/SPX.
  • C 18-й версией библиотеки защиты НБУ выводится диалоговое окно с предупреждением об окончании срока действия ключа.
  • Добавлен параметр #ConnectTimeOut, который задает максимальное время для установки соединения.
  • Разблокированы кнопки на панели инструментов при открытом окне с настройками TCPFoss.
  • Ускорена работа с приоритетами.
  • В журнал ошибок пишется информация о неудачных попытках создать принимаемый файл.
  • При проверке на дубль вначале проверяется наличие файлов в папке Tmp.
  • Параметр #TxQueue может принимать значения от 1 до 255.
  • При приостановке передачи низкоприоритетных файлов в журнале фиксируется cps.


V

V4.5.7
  • Параметр #Pri стал локальным.
  • В предыдущих версиях при включенной подписи файла, если один из файлов не смог быть принят (код ошибки 3), то остальные файлы не принимаются из-за несовпадения подписи (код ошибки 12). До внесения исправлений с библиотеку защиты, с этой проблемой борется TCPFoss.
  • Сделаны правки при работе с параметрами, значение которых зависит от времени.


V

V4.5.6
  • Устранена проблема с допередачей при включенном сжатии и шифровании (подписи) файлов.
  • Исправлены сообщения об ошибках при работе с файлом журнала НБУ (#NbuLog).
  • Не выводится сообщение о том, что файл журнала НБУ (#NbuLog) имеет 0-ю длину.
  • Устранена ошибка, из-за которой мог не закрываться журнал НБУ за предыдущий день.
  • Исправлено сообщение об ошибке, которое выводится, если найдена папка, заданная параметром #NbuSert


V

V4.5.5
  • Устранена проблема с допередачей сжатых файлов при обмене со старыми версиями TCPFoss(до 4.5.0).
  • Сделаны изменения для работы с V14 и V15 библиотеки защиты НБУ.


V

V4.5.4
  • Исправлена ошибка при работе с #LanTry. Ошибка появилась в версии V4.5.0. Переход на резервный канал связи происходил, даже если ошибок обмена по сети не было.
  • В лог-файле снова фиксируется имя dial-up соединения (при #LogFmt =0, #LogFmt =1).


V

V4.5.3
  • Сделаны изменения для работы с V15 библиотеки защиты НБУ. Эта версия библиотеки может работать с ключами на touch memory.


V

V4.5.2
  • Иногда, при восстановлении абонентом прерванного соединения, TCPFoss аварийно завершался. В этой версии проблема устранена.


V

V4.5.1
  • В командной строке добавлен параметр /tray - запуск программы свернутой в трей.
  • Каталоги, заданные параметрами #Log, #LogErr, #NbuLog,NbuLog создаются автоматически, если в имени каталога встречаются метасимволы %D, %Y и т.д.
  • Исправлена ошибка из за которой передача зашифрованных/подписанных могла прерываться.


V

V4.5.0
  • Внимание!!! Произошла смена серийных номеров.
  • В библиотеку защиты НБУ добавлены функции блочного шифрования и подписи, расширены коды ошибок. В TCPFoss добавлена поддержка этих функций. Появление блочного шифрования уменьшило объем передаваемой информации на 12.5%.
  • Внимание!!! При включенной аутентификации НБУ программа не совместима с предыдущими версиями.
  • Добавлен параметр #NbuMac.
  • Сообщения "Отослан свой сертификат", "Получен сертификат от абонента" записываются в лог файл всегда, независимо от значения параметра #NbuLogLevel.
  • Исправлена ошибка, из-за которой не инициализировалась система защиты, если до конца срока действия ключа оставалось менее шести дней.
  • Устранена ошибка, которая приводила к появлению сообщений "Неизвестный абонент", если при старте программы были проблемы с инициализацией защиты НБУ.
  • При ошибках аутентификации делаются повторные попытки выхода на связь.
  • Можно узнать какая ошибка аутентификации возникла у абонента.
  • Добавлен код ошибки 12 (Ошибка подписи/шифрования файла).
  • В меню "Защита" добавлена команда "Версия библиотеки".
  • В меню "Файл" добавлена команда "Перезагрузка".
  • Лог файлы за предыдущий день закрываются в полночь, а не при выходе на связь.
  • Для параметров #Scan, #Polling, #ReScan, #Break, #BreakPause, #RasPause, #RasTimeOut, #MaxTxCps, #MaxRxCpsSetup можно задавать разные значения, в зависимости от времени и дня недели.


V

V04.04.2
  • При ненулевом значении #LanTry и работе по локальной сети в лог файле не пишется строка "via phone...."
  • Добавлена возможность сворачивать программу в трей - в меню "Вид" появилась команда "Сворачивать в трей".


V

V04.04.1
  • При внесении доработок в библиотеку защиты НБУ, перестало работать шифрование файлов. В этой версии сделаны необходимые изменения.


V

V04.04
  • Внимание!!! Произошла смена серийных номеров.
  • Используется новая версия библиотеки защиты. Эта версия библиотеки загружает процессор значительно меньше предыдущей. Она не совместима с предыдущими версиями.


V

V04.03.11
  • Добавлен параметр #ReScan.
  • Изменена минимальная ширина столбцов в основном окне и окне с подробной информацией.


V

V04.03.10
  • Используется последняя версия библиотеки сжатия - zlib1.
  • В логе фиксируется время смены имени файла.
  • Изменен разбор файла конфигурации. Комментарий начинается с символа ';', а не с пробела.


V

V04.03.9
  • Исправлена обработка параметра #Auten.
  • Добавлен параметр #AllShow.
  • Добавлен параметр #ConnectRetry, который задает число попыток соединения, перед тем как положить трубку.


V

V04.03.8
  • Добавлены параметры #RasConn, RasConn_1, ..., RasConn_9RasConn
  • В лог файле фиксируются обрывы обмена.
  • Устранено появление ложных сообщений "Обмен прерван".
  • Устранена ошибка при подсчете количества переданных/принятых байт в строке END CONNECTION лог файла. До этого, при разрыве канала связи дважды учитывалась длина полностью переданных файлов, для которых не пришла квитанция об их успешном приеме.


V

V04.03.7
  • Исправлена автоматическая настройка маршрутных таблиц (параметр #AddRoute). Теперь она может работать совместно с RRAS.


V

V04.03.6
  • Добавлены параметры в командной строке: /Min - Запуск в минимизированном окне; /Max - Запуск в максимизированном окне.
  • В лог пишется информация о причинах ошибки чтения или записи.


V

V04.03.5
  • Устранена ошибка в отображении окна с подробной информацией, которая могла вызвать exeption при интенсивном обмене.
  • В окне с подробной информацией отображается мгновенный cps.


V

V04.03.4
  • Восстановлена работоспособность под Win95.


V

V04.03.3
  • При переходе через сутки старые логи закрываются.


V

V04.03.2
  • Устранена проблема при смене лог файла.
  • Добавлена возможность автоматической настройки маршрутных таблиц (параметр #AddRoute).


V

V04.03.1
  • Изменен алгоритм работы с лог файлами.
  • Неудачная попытка избавиться от использования dial-up соединения, как маршрутизатора по умолчанию.
  • Добавлены новые сообщения об ошибках аутентификации.
  • Устранена ошибка библиотеки mfc42, которая не давала запускаться программе при поврежденном файле TCPFoss.ini.


V

V04.03
  • Внимание!!! Произошла смена серийных номеров.
  • Версия сделана на базе V03.20 и V4.02.
  • Устранено появление в log файле строки S1 для успешно переданных файлов.
  • При приеме сжатых файлов в папке #DebugInp сохраняются распакованные файлы.
  • В log файле записывается код завершения программы.
  • Снижена загрузка процессора при включенном ограничении скорости приема или передачи.
  • Устранена ошибка, из-за которой высокоприоритетные файлы не вытесняли передачу низкоприоритетных файлов. Ошибка появилась в версии V03.18.
  • У клиентской версии TCPFoss расширено окно состояния абонента, чтобы полоса прокрутки не перекрывала его.
  • Удален параметр #DebugOut.
  • Последние #LogRows строк в окне с подробной информацией накапливаются сразу после запуска программы (раньше, только после того, как окно было открыто в первый раз).
  • Появилась возможность автоматического перехода на обмен через модем, при появлении проблем с обменом по локальной сети (параметры #LanTry и #Host).
  • Для синхронизации с внешними программами добавились параметры #ConnectEvent и #DisconnectEvent.


V

V04.02
  • В файле протокола работы фиксируется ip адрес абонента.
  • Используется новая версия библиотеки защиты.


V

V04.01
  • Внимание!!! Произошла смена серийных номеров.
  • Версия сделана на базе V03.16 и V04.00.
  • Исправлена ошибка, иногда приводившая к появлению дублей файлов, при очень частых обрывах соединений.
  • Добавлена возможность перезаписи существующих файлов. См. параметр #RxRename.
  • При наличии ошибок в файле конфигурации не появляется пункт меню "Защита", т.к. выбор этого меню приводил к аварийному завершению программы.
  • Исправлено некорректное поведение программы, возникающее в случае отсутствия таблицы открытых ключей. После выбора пункта «Просмотр ключа» в меню «Защита» сообщение об ошибке выдавалось только первый раз.
  • Пункт «Просмотр ключа» в меню «Защита» теперь содержит имя абонента, чей ключ будет просматриваться.
  • Эта версия не распространялась, а только тестировалась в НБУ.


V

V04.00
  • Внимание!!! Произошла смена серийных номеров.
  • В этой версии была введена аутентификацииAutentif абонента с использование библиотеки Национального банка Украины. В остальном, эта версия совпадает с версией V03.15.
  • Эта версия не распространялась, а только тестировалась в НБУ.


V

V03.20
  • Появилась возможность сжатия файлов во время передачи (параметры #Compress, #NoCompress).
  • Можно отключить splash окно, запустив программу с ключом /NoSpalsh.
  • В главном окне программы можно сортировать абонентов по имени, времени, состоянию.
  • При запуске программы открываются все окна, которые были открыты перед завершением.
  • Добавлен параметр #Comment.
  • Параметр #CanClose блокирует команду Файл->Свойства, одновременно с командой Файл->Открыть.
  • Программа выгружается из памяти, если ее завершить во время редактирования файла конфигурации.
  • В окне с подробной информацией файлы, переданные/принятые в разных сессиях обмена, отображаются разными цветами.
  • Параметр #TxRename переименован в #RxRename, что выглядит логичней.
  • Добавлена возможность перезаписи существующих файлов. См. параметр #RxRename


V

V03.19
  • Появилась индикация, когда на сервер выходит клиент с неверным паролем.
  • Можно ограничивать скорость передачи и приема (параметры #MaxTxCps, #MaxRxCps).
  • В логе фиксируется IP адрес абонента.


V

V03.18
  • В лог файле имена файлов отображаются в том же регистре, что и на диске.
  • Устранен exeption при перезагрузке системы.


V

V03.17
  • Устранена ошибка, приводившая к тому, что глобальный лог не открывался в начале следующего дня.
  • Устранено появление дублей файлов при очень частых обрывах обмена.


V

V03.16
  • Добавлен параметр #RasTimeOut.
  • Добавлен параметр #SoundErrTimeOut.
  • Исправлена ошибка в help файле: Параметр #SoundErr перенесен в раздел "Локальные параметры".
  • Восстановлен пропавший параметр #RasPhone.
  • Добавлена возможность редактирования файла конфигурации.
  • Устранена ошибка, приводившая к появлению в журнале, заданном параметром #LogErr, пустых строк.
  • Устранена ошибка, которая при #LogLevel = 1, приводила к появлению строки END CONNECTION даже при неудачном выходе на связь.
  • Расширены возможности параметра #LogLevel.
  • Программа может работать как сервер автоматизации.


V

V03.15
  • Исправлена ошибка, появившаяся в V03.14, из-за которой в файле с протоколом работы не отражалось переименование файлов.
  • Исправлена ошибка, из-за которой не работала допередача файлов со временем создания, содержащее нечетное количество секунд. Допередача отсутствовала при передаче с NTFS на FAT.
  • При задании параметра #LogErr можно использовать символы %Y и %y.
  • Возможно указание приоритета ниже *.*
  • Устранено появление сообщения "Выходной буфер переполнен".
  • При испорченном файле защиты от дублей программа выдает сообщение оператору, и продолжает работу. Раньше - останавливалась, поэтому оператор должен был вручную удалять испорченный файл.
  • Появилась индикация количества абонентов.


V

V03.14
  • Теперь программа работает без dll файлов.
  • Добавлен параметр #LogLevel.
  • При задании параметра #Log можно использовать символы %Y и %y.
  • Если протокол работы ведется в общем файле в формате FOSSMAIL, то в нем появляется поле с именем абонента.
  • Добавленыпараметры#RasPhone, (#RasPhone_1, ..., #RasPhone_9).
  • Устранено зависание программы, иногда происходившему при выходе на связь незарегистрированного абонента.
  • Исправлена ошибка при работе с резервными телефонами.
  • Сняты ограничения для параметра #BlkRx
  • Добавлены hotkeys. ALT+S для кнопки [image] (Остановить) и ALT+C для кнопки [image] (Вызвать).
  • Теперь можно работать через SOCKS4, SOCKS5 Proxy с использованием программы SocksCap32.
  • Окно с подробной информацией теперь перерисовывается каждую секунду. Возможно, теперь не будет жалоб на то, что программа иногда работает в полудуплексе.
  • Если при обрыве канала связи, клиент в течение 2-х минут успевал снова соединиться с сервером, то он получал сообщение "Абонент занят". Сейчас эта проблема устранена.
  • Появилась новая иконка [image] , индицирующая наличие ошибок ввода вывода при проведении обмена.


V

V03.13
  • Устранена ошибка, приводившая к аварийному завершению программы, при приеме файла с некорректной датой создания, например: 0.0.2006 или 1.1.1979.
  • Устранена ошибка, приводившая к аварийному завершению программы, при поврежденном файле %WINDOWS%\TCPFoss.ini.
  • При разрывах канала связи не полностью переданные и принятые файлы не учитываются в сообщении "Обмен прерван. Передано X. Принято Y.".
  • Кнопка [image] (Остановить), во время обмена с абонентом, всегда доступна.
  • Добавленыпараметры#RasUser .
  • Добавленыпараметры #RasPsw .
  • Добавленыпараметры #RasDomain.
  • Добавленпараметр #RxShort.
  • Добавлены параметры #LogErr и #SoundErr.
  • Добавлены параметры #DebugOut, #DebugInp и #LogCrc.


V

V03.12
  • Устранена ошибка, переводившая абонента в состояние "Вызов остановлен", при ошибке чтения файла открытых ключей.
  • Теперь, при разрыве канала связи, когда абонент еще не успел сообщить свое имя, не выводится сообщение "Неизвестный абонент".
  • Теперь, если имя абонента неизвестно, вместо сообщения "Без имени" выводится IP адрес.
  • Устранены ошибки при работе с файлом протокола. Теперь:
  • Общий протокол ведется и после повторного открытия файла конфигурации;
  • - Номер канала и время последнего выхода на связь при закрытии протокола выводятся корректно.
  • Сделаны коррекции при работе со временем создания файла.
  • Сообщения "Отказал в доступе" и "Отказано в доступе" теперь не перекрываются сообщением "Вызов остановлен".


V

V03.11
  • Добавлен локальный параметр #Auten
  • Добавлен локальный параметр #TimeOut.
  • Кнопка [image] (Остановить), теперь может прерывать обмен и с абонентом, являющимся клиентом данного узла.


V

V03.10
  • Наконец-то написан help.
  • При закрывании окна с подробной информацией фокус возвращается в основное окно программы.
  • Теперь при описании абонента можно задать, что часть модемов подключена к выделенной линии, а часть к коммутируемой.
  • Добавлены параметры #RasUser, #StartupPause и #TcpClosePause
  • Устранена ошибка при ведении протокола работы в общем файле, иногда приводившая к аварийному завершению программы.
  • Введены коды возврата.
  • При установке канала связи теперь выводится имя соединения. В протокол также заносится имя соединения, по которому шел обмен.
  • Исправлена ошибка при работе со временем создания файла, приводившая к тому, что время создания файла на передающей и приемной стороне могли отличаться, если у абонентов были разные настройки часовых поясов. Это исправление действует только при работе новых версий.


V

V03.09
  • Теперь все файлы перекладываются из папки, заданной параметром #Out в папку, заданную параметром #OkOut, если это заказывалось.
  • В предыдущей версии, после того как истек интервал времени, заданный параметром #BreakPause, повторный выход на связь происходил только при наличии файлов в папке #Out В этой версии эта ошибка устранена.


V

V03.08
  • При перекладке файлов из папки #Out в #OkOut, теперь используется такой же алгоритм, как и при перекладке из Tmp в Inp. Т.е. при возникновении ошибки при перекладке операция повторяется #ErrRetry раз с интервалом #ErrPause При неудачном завершении в файл протокола заносится строка Err rename.
  • Добавлены кнопки [image] (Вызвать) и [image] (Остановить). Кнопка "Остановить" теперь прерывает обмен файлами и останавливает вызов абонента.
  • Количество строк отображаемых в окне с подробной информацией теперь задается в файле конфигурации глобальным параметром #LogRows Значение по умолчанию 30 строк.
  • Dll для работы с удаленным доступом теперь загружается динамически. Если в файле конфигурации нет обращения к удаленному доступу, то dll не загружается.
  • Расширены возможности параметров #Scan, #Polling, #Break Добавлен параметр #BreakPause
  • Параметр #RasPause стал локальным.
  • Появился параметр #CanClose.


V

V03.07
  • Время начала сессии теперь выводится правильно.
  • Устранена ошибка, вызывающая исключение C0000005 по адресу 0040862A.
  • Переименованы параметры #CntRetry в и #CntPause в #ErrPause
  • Расширен синтаксис параметра #Host


V

V03.06
  • Введена защита от появления дублей при обрыве канала связи. Для реализации этой защиты в папке, заданной параметром #Out создается подкаталог Tmp, в котором хранится служебная информация. Передачу дубля можно определить по нулевому cps в файле протокола. Защита действует только при работе программ версии V03.06 и выше.
  • Важнейшие дисковые операции (удаление успешно переданных файлов и перекладка из папки Tmp в Inp) при возникновении ошибок повторяются несколько раз. Новый параметр в файле конфигурации #ErrRetry задает число попыток (по умолчанию 5), а параметр #ErrPause интервал между попытками, в сек (по умолчанию 1 сек). Надеюсь, что так можно будет избавиться от дублей при перегрузке NOVELLовского сервера.
  • В параметре #Log теперь можно указывать символ #, который заменяется именем абонента. Убедитесь, что # и %N не присутствуют вместе, т.к. такая возможность пока не реализована. Кроме того, теперь допускается вести один файл протокола для всех абонентов и каналов.
  • Файл протокола теперь всегда закрывается между сессиями. Если прокол не удается открыть, то обмен не производится, а у абонента появляется сообщение "Нет протокола для абонента", если ошибка произошла на данном компьютере и "Нет протокола у абонента", если ошибка произошла на удаленном компьютере.
  • Сохраняются размеры и положение не только основного окна, но и окон с подробной информацией.
  • В параметре #Host после адреса абонента через двоеточие можно указать другой номер порта, например:
  • #Host = U0H0 200.1.1.1:10012 +
  • #Host = UUUU UUUU:10010 -


V

V03.05
  • Поддержка длинных имен файлов
  • Многоканальность
  • Приоритеты отправки файлов с возможностью приостановки передачи низкоприоритетного файла.
  • Более ранние версии V03 не распространялись.


VXX

V02.XX
  • Два уровня приоритетов отправки файлов, без возможности приостановки передачи низкоприоритетных файлов.
  • Новый протокол обмена файлов, повышающий скорость обмена при передаче коротких файлов.
  • Программаработаетпод Dos, Windows 3.11, Windows 95, Windows NT, Unix, Os/2.


VXX

V01.XX
  • Передача файлов по TCP/IP
  • Дуплексная передача данных.
  • Только Dos версия.


Установка программы

Установка программы

Программа распространяется либо в инсталляционном файле Tcpfoss_ruNNN.msi, либо в архивном файле TCPFossNNN.zip, где NNN - номер версии программы.

Архив содержит саму программу TCPFoss.exe, справочные файлы и заготовки файлов конфигурации.

Для установки программы создайте на диске папку, в которой Вы собираетесь хранить программу (в заготовке файла конфигурации предполагается C:\TCPFoss), и распакуйте туда архивный файл.

Узнайте имя (Name) и IP адрес абонента (Addr), а также имя и пароль для подключения к серверу абонента через модем.

Настройте операционную систему, установив протокол TCP/IP, удаленный доступ к сети и создав соединение для подключения к абоненту.

Настройте программу, отредактировав заготовку файла конфигурации TCPFoss.tcp:

  • Отредактируйте значение параметра #Name, внеся туда свое почтовое имя.
  • Отредактируйте значение параметра #Serial, внеся туда серийный номер из Вашей лицензии.
  • Отредактируйте параметр #Host, внеся в него имя (Name) и адрес (Addr) абонента и тип канала связи (выделенный, коммутируемый).
  • В папке C:\ TCPFoss создайте папку с именем абонента Name, а в ней папки Inp и Out.
  • Сообщите Вашему абоненту о своем подключении. Ему необходимо зарегистрировать Вас, добавив в свой файл конфигурации параметр #Host с Вашим именем.


Настройка программы

Настройка программы

Программа настраивается с помощью файла конфигурации, содержащего ряд строк следующей структуры:

#Имя = Значение Комментарий

Имя - имя параметра. Символ # перед именем параметра можно опускать;

Значение - значение параметра;

Комментарий - Остаток строки, начинающийся с символа ";".

Параметры делятся на глобальные, локальные и описатели абонентов. Глобальные параметры определяют поведение программы для всех абонентов. Описатель абонента #Host задает имя абонента, его адрес и канал связи. Локальные параметры определяют поведение программы для абонента, описанного параметром #Host.

Если локальный параметр задан до первого появления параметра #Host, то он задает значение по умолчанию для данного параметра.

Для параметров помеченных значком [image] после значения параметра можно указать его время действия. Для этого используются следующие сокращения:

  • Mo - понедельник
  • Tu - вторник
  • We - среда
  • Th - четверг
  • Fr - пятница
  • Sa - суббота
  • Su - воскресенье
  • Wk = Mo-Fr (рабочая неделя)
  • Al = все дни недели

Задание расписания поясним на примере:

#Scan = 10 Mo; В понедельник параметр Scan равен 10

#Scan = 20 Tu 10:00-24:00; Во вторник с 10:00 до 24:00 параметр Scan равен 20

#Scan = 30 We,Fr,Su 9:00-16:00; В среду, пятницу и воскресенье параметр Scan равен 30

#Scan = 40 Fr-Mo 00:00-9:00; С пятницу, субботу, воскресенье и понедельник с 00:00 по 9:00 параметр Scan равен 40

#Scan = 50; Всю неделю, круглые сутки, за исключением интервалов описанных выше,

; параметр Scan равен 50

Примечание: Поиск интервала идет сверху вниз, до первого совпадения. Поэтому при наличии перекрывающихся интервалов, будет использоваться верхняя строка.


Глобальные параметры

Глобальные параметры

В программе используются следующие глобальные параметры:


#Name

#Name

Параметр задает имя узла, на котором запущена программа. Абонент этого узла должен указать это имя в параметре #Host Например:

#Name = AAAA


#Serial

#Serial

Параметр задает серийный номер программы. Значение задается разработчиком при покупке программы. Например:

#Serial = 1234567890


#Title

#Title

Параметр задает имя основного окна программы (введен начиная с V03.05). По умолчанию принимается имя TCPFoss. Например:

#Title=”Тест”


#Port

#Port

Параметр задает номер TCP порта. Выбор номера осуществляется произвольно. Он должен быть больше 5000, и не должен вступать в противоречие с каким-либо портом TCP-сервера. Все программы взаимодействующие друг с другом должны иметь один и тот же номер. Если в качестве номера указано отрицательное число, то программа не будет работать как сервер. Например:

#Port = 10000


#TxZero

#TxZero

Параметр указывает, передавать ли файлы с нулевой длиной. Если этот параметр равен нулю, то файлы с нулевой длиной не передаются (это значение по умолчанию), в остальных случаях нулевые файлы будут передаваться. Например, строка, запрещающая передачу файлов с нулевой длиной.

#TxZero = 0


#OutLine

#OutLine

Параметр задает количество каналов, которое может быть использовано для исходящих соединений. По умолчанию равно максимальному числу каналов поддерживаемых программой. Например:

#OutLine = 2


#RxRename

#RxRename

Параметр определяет, переименовывать ли файлы с совпадающим именем. Если этот параметр равен нулю, то переименование запрещено. При появлении файла с совпадающим именем прием файла завершается с кодом ошибки 5. Если параметр равен единице (значение по умолчанию) то у файла изменяется расширение на .001, .002, ...,.999. Если параметр равен двум, то файл перезаписывается. Например:

#RxRename = 1


#AddTxLen

#AddTxLen

Параметр определяет минимальную длину файла, начиная с которой ведется проверка на возможность допередачи файла. Проверка на допередачу требует некоторого обмена данными и для коротких файлов выгоднее передать весь файл заново, чем проверять возможность допередачи. Значение по умолчанию 2048. Например:

#AddTxLen = 2048


#TxQueue

#TxQueue

Параметр определяет длину очереди на передачу - количество файлов, которые можно передать без получения квитанции об успешной передаче. Этот параметр оказывает влияние на производительность программы, особенно при использовании канала связи с большими задержками, например спутниковыми. Значение по умолчанию 10. Например:

#TxQueue = 10


#BlkTx

#BlkTx

Параметр задает размер буфера для передачи. По умолчанию он равен 1024. Размер буфера определяет размер TCP/IP пакета (он равен #BlkTx+Размер TCP и IP заголовков). Изменяя этот параметр можно подстроить размер TCP/IP пакета под соответствующую аппаратуру и тем самым увеличить скорость передачи. Например:

#BlkTx = 1024


#BlkRx

#BlkRx

Параметр определяет размер буфера для приема. По умолчанию он равен 1024. Увеличивая этот параметр можно увеличить скорость приема.

Замечание: До V03.13 включительно, не следует задавать значение этого параметра менее 530 байт.

#BlkRx = 1024


#Log

#Log

Параметр указывает папку и имя файла, в котором будет вестись протокол работы программы. Если этот параметр опущен - протокол вестись не будет.

Имя файла может содержать символы:

  • %Y - заменяются на четыре цифры текущего года. До версии V03.13 включительно - на последние две цифры текущего года;
  • %y - заменяются на две последние две цифры текущего года;
  • %M - заменяются на две цифры текущего месяца;
  • %D - заменяются на две цифры текущей даты;
  • %N - заменяется на номер канала. Этот символ обязательно (до V03.05 включительно) должен присутствовать в имени файла;
  • # - заменяется на имя абонента (начиная с V03.06).

Если вместо имени указан только подкаталог, то в качестве имени принимается %Y%M%DT%N.LOG

#Log = C:\ TCPFoss\LOG\%Y%M%DT%N.LOG


#LogFmt

#LogFmt

Параметр задает формат файла протокола. Допустимы четыре формата:

  • формат FOSSMAIL (значение параметра 0);
  • формат FOSSMAIL без вертикальных разделителей (значение параметра 1);
  • формат PROCARRY (значение параметра 2);
  • формат SAVEBANK (значение параметра 3).

Значение по умолчанию 0.

#LogFmt = 0


#LogRows

#LogRows

Параметр задает число строк, которые отображаются в окне с подробной информацией. См. команду [image] (Открыть) в меню "Абонент". Значение по умолчанию 30 строк.

#LogRows = 30


#AllShow

#AllShow

При ненулевом значении параметра данные для окон с подробной информацией накапливается в памяти сразу после запуска программы. При нулевом значении параметра данные начинают накапливаться после выполнения команды [image] (Открыть) из меню "Абонент".

Параметр введен в версии V04.03.9. Значение по умолчанию 1. При большом количестве абонентов, для повышения производительности рекомендуется установить значение параметра равным нулю.

#AllShow = 1


#LogCrc

#LogCrc

Параметр введен в версии V03.13 в отладочных целях. Если этот параметр отличается от нуля, то в протоколе работы будет сохраняться контрольная сумма переданных и принятых файлов.

Значение по умолчанию 0.

#LogCrc = 0


#LogLevel

#LogLevel

С помощью этого параметра в протоколе работы и ошибок, можно фиксировать дополнительную информацию.

Параметр задается как сумма констант:

1 - в протоколе работы регистрировать все удачные выходы на связь, включая те, где файлов для обмена не было;

2 - в протоколе работы регистрировать все попытки дозвона. (Начиная с версии V03.16);

4 - в протоколе работы регистрировать все неудачные попытки дозвона. (Начиная с версии V03.16);

8 - в протоколе ошибок регистрировать все неудачные попытки дозвона. (Начиная с версии V03.16);

Параметр введен в версии V03.14. Значение по умолчанию 0.

#LogLevel = 0


#Private

#Private

Параметр указывает на имя файла с закрытым ключом для абонента с именем #Name. Используется совместно с параметром для проведения аутентификации при вхождении в связь. Если параметр опущен, аутентификация не проводится.

#Private = p1.s$$


#Public

#Public

Параметр указывает на имя файла с открытыми ключами абонентов (См. параметр #Private).

#Public = p_all.s$$


#CloseWin

#CloseWin

Параметр задает имя окна, которое появляется при разрыве модемного канала связи. Для английской версии Windows 95 – "Reestablish Connection". Для русской версии - "Восстановление связи" (редактируйте этот параметр средствами Windows). Этот параметр нужен для обхода ошибки в удаленном доступе Windows 95. В версии Windows 95 OSR2 эти ошибки устранены, и пользоваться этим параметром необязательно. Значения по умолчанию нет.

#CloseWin = "Reestablish Connection"


#MinWin

#MinWin

Параметр задает имя окна, которое появляется при установке модемного канала связи. Это окно будет минимизировано программой TCPFoss. В версии Windows 95 OSR2 окно минимизируется автоматически, так что пользоваться этим параметром необязательно. Значения по умолчанию нет.

#MinWin = "Connect to"


#ErrRetry

#ErrRetry

Параметр определяет число попыток на выполнение важнейших дисковых операций (удаление успешно переданных файлов, перекладка из Tmp в Inp) при возникновении ошибок. Значение по умолчанию 5. Параметр введен с версии V03.06 для устранения появления дублей по вине NOVELLовского сервера. Параметр #ErrPause задает интервал между попытками.

#ErrRetry = 5


#ErrPause

#ErrPause

Параметр задает интервал между попытками на выполнение важнейших дисковых операций, сек. Значение по умолчанию 1 сек. Параметр введен с версии V03.06.

#ErrPause = 1


#CanClose

#CanClose

Параметр определяет возможность завершения программы по команде оператора. Этот параметр состоит из битовых флагов. При сброшенном нулевом бите запрещается команда Alt-F4. Сброшенный первый бит запрещает команду "Выход" из меню "Файл". Сброшенный второй бит запрещает команды "Открыть" и "Свойства" данного меню. Сброшенный третий бит запрещает программе завершаться при получении сообщения WM_ENDSESSION. По умолчанию значение параметра равно 15, т.е. все команды разрешены.

#CanClose = 15


#StartupPause

#StartupPause

Параметр задает паузу между запуском программы и попыткой установить модемный канал связи, в сек. Параметр введен в V03.10 для устранения зависания RAS сервера на Windows NT.

RAS сервер имеет некоторую "особенность". Если в течение примерно 15 сек после его запуска попытаться установить модемное соединение, он перестает работать. Если Вы хотите, чтобы TCPFoss работал в группе "Автозагрузка" добавьте в файл конфигурации параметр #StartupPause = 30. В течение 30 сек после запуска, TCPFoss не будет пытаться устанавливать модемные соединения.


#RxShort

#RxShort

Параметр указывает, преобразовывать ли длинное имя принятого файла в короткое. Если этот параметр равен нулю (это значение по умолчанию), то преобразование не производится, в остальных случаях длинное имя будет преобразовано в короткое имя. Параметр введен в версии V03.13.

#RxShort = 0


#LogErr

#LogErr

Параметр указывает папку и имя файла, в котором будут записываться сообщения типа "Абонент не выходит на связь", "Абонент не отвечает". Параметр введен в версии V03.13.

Имя файла может содержать символы:

  • %у - заменяются последними двумя цифрами текущего года;
  • %Y - заменяются цифрами текущего года;
  • %M - заменяются двумя цифрами текущего месяца;
  • %D - заменяются двумя цифрами текущей даты;

Если вместо имени указана только папка, то в качестве имени принимается TCPFoss.ERR

#LogErr = C:\ TCPFoss\LOG\ TCPFoss.ERR


#NbuPrivate

#NbuPrivate

Параметр должен указывать на имя устройства, в котором храниться закрытый ключ НБУ. Параметр является обязательным при включенной аутентификации НБУ и при его отсутствии обмен не начинается. Был введен в версии V04.00.

Значение параметра зависит от регистра символов.

#NbuPrivate = a:


#NbuPublic

#NbuPublic

Параметр указывает на папку, в которой хранится таблица открытых ключей НБУ, индексы, журналы криптосистемы НБУ и т.д. Параметр введен в версии V04.00 и является обязательным при включенной аутентификации НБУ. При его отсутствии обмен не начинается.

#NBuPublic = C:\ TCPFoss\KEY


#NbuSert

#NbuSert

Параметр указывает на папку, в которой TCPFoss будет искать сертификат открытого ключа НБУ. Параметр введен в версии V04.00 и является обязательным при включенной аутентификации НБУ. При его отсутствии обмен не начинается.

#NbuSert = C:\ TCPFoss\SERT


#NbuLog

#NbuLog

Параметр указывает папку и имя файла, в котором будут записываться протокол работы TCPFoss с библиотекой защиты НБУ. Параметр введен в версии V04.02 и является обязательным при включенной аутентификации НБУ.

Имя файла может содержать символы:

  • %y - заменяются последними двумя цифрами текущего года;
  • %Y - заменяются четырьмя цифрами текущего года:
  • %M - заменяются двумя цифрами текущего месяца;
  • %W - заменяются номером дня недели;
  • %D - заменяются двумя цифрами текущей даты;
  • %N - заменяются именем данного узла (Имя узла задается параметром #Name).

#NbuLog = С:\ TCPFoss\LOG\ TCPFoss.NBU


#NbuLogLevel

#NbuLogLevel

Если значение параметра равно нулю, то в файле, заданном параметром #NbuLog будут фиксироваться только неудачные вызовы функции библиотеки защиты. Если параметр равен единице - все. Значение по умолчанию - 0.

Параметр введен в версии V04.02.

#NbuLogLevel = 0


#NbuWarning

#NbuWarning

Параметр введен в версии 4.5.11. С его помощью можно указать, за сколько дней выдавать предупреждение об истечении срока действия закрытого ключа. Значение по умолчанию 7.

#NbuWarning = 7


#DelayWrite

#DelayWrite

Параметр введен в версии V4.5.11. С его помощью можно включить отложенную запись (кэширование) принимаемых файлов. Включение отложенной записи значительно ускоряет прием коротких файлов, но является потенциальным источником проблем. Tcpfoss принимает файл, успешно записывает его в кеш и уведомляет передающую сторону об успешном приеме. При сохранении кэша на диск, может возникнуть ошибка. Она обрабатывается операционной системой – выводится сообщение об ошибке отложенной записи - и не попадает в Tcpfoss.

В результате по логам Tcpfoss файл был успешно принят, а на диске его нет.

Значение по умолчанию 0.

#DelayWrite = 0


Описатель абонента

Описатель абонента

В программе используются следующий параметр для описания абонента:


#Host

#Host

Задает имя, адрес и тип канала связи абонента, с которым будет вестись обмен файлами. Должны быть описаны все абоненты, работающие с этим узлом (как клиенты, так и серверы).

Параметр имеет следующий формат:

#Host = Name Addr KC

Name - почтовое имя абонента, заданное в файле конфигурации абонента параметром #Name

Addr - IP адрес абонента, например 200.1.2.9. Возможно использование DNS и WINS адресов. Начиная с V03.06 после адреса через двоеточие можно указать номер TCP порта, например 200.1.2.9:10011. Начиная с V4.5.8 через запятую можно ввести несколько IP адресов, например 200.1.2.9:10011, 200.1.2.10, 200.0.1.2.11:10012. Адреса будут перебираться, начиная с первого, при неудачном соединении. Другой способ указать альтернативные адреса, это использование параметров #LanAddr, #RasAddr.

KC - Тип канала связи с этим абонентом, задается символом:

  • Плюс (+) - Выделенная линия. Доступ через удаленный доступ. Не разрывать канал после проведения обмена. Начиная с версии V03.10 после символа + можно указать количество выделенных линий. Например, КС +3 будет указывать, что первых три телефонных номера будут выделенными, а оставшиеся коммутируемыми.
  • Минус (-) - Коммутируемая линия. Доступ через удаленный доступ. Разорвать канал после проведения обмена.
  • Пробел ( ) - Постоянный канал связи, например локальная сеть.
  • Звездочка (*) - Абонента не вызывать.

Начиная с версии V04.03 перед символом + и - можно указать число попыток связаться по локальной сети (записываются без пробелов), перед тем как начать использовать модем. Другой способ задать число попыток, это использовать параметр #LanTry. Например:

#host = UUUU 1.2.3.4:10011 3+1

Абонент: UUUU

Ip адрес: 1.2.3.4

Порт:10011

Число попыток связи по локальной сети:3

Число выделенных линий:1

Адрес и тип канала связи могут быть опущены при описании абонента, являющегося клиентом данного узла (абонент будет сам выходить на связь). Другим способом описания такого абонента является указание типа канала связи - *.

При доступе к абоненту через модем (средствами удаленного доступа) в качестве имени соединения используются строки Name, Name_1, ..., Name_9, где Name - имя абонента. Например, для абонента UUUU необходимо завести в телефонной книге удаленного доступа хотя бы одно из соединений UUUU, UUUU_1, UUUU_2, ..., UUUU_9. (См. раздел "Настройка операционной системы"). Начиная с V04.03.8 имена соединений можно переопределить с помощью параметров #RasConn, #RasConn, #RasConn.


Локальные параметры

Локальные параметры

В программе используются следующие глобальные параметры:


#Out

#Out

Параметр задает имя выходного почтового ящика абонента. Из этого ящика выбираются файлы для отправки. Символ # в имени ящика заменяется именем абонента. По умолчанию используется значение параметра #Out, указанное в файле до первого появления параметра #Host. Например:

#Out = C:\ TCPFoss\#\OUT


#Inp

#Inp

Параметр задает имя входного почтового ящика абонента. В этот ящик будет вестись прием файлов. Символ # в имени ящика заменяется именем абонента. По умолчанию используется значение параметра #Inp, указанное в файле до первого появления параметра #Host. Например:

#Inp = C:\ TCPFoss\#\INP


#OkOut

#OkOut

Параметр задает имя ящика, в который будут перекладываться успешно переданные файлы. Если имя ящика не задано, то успешно переданные файлы будут удаляться. Символ # в имени ящика заменяется на имя абонента. По умолчанию используется значение параметра #OkOut, указанное в файле до первого появления параметра #Host. Например:

#OkOut = C:\ TCPFoss\#\OKOUT


#Pri

#Pri

Маска приоритетных файлов. Может быть определено до 8-ми масок. Маска указанная ранее имеет более высокий приоритет. Более приоритетные файлы передаются раньше низкоприоритетных и могут откладывать их передачу. Значение по умолчанию #Pri = *.*.

Этот параметр отсутствует у клиентской версии программы TCPFoss.

Следующая конфигурация задает поддержку приоритетов как в версии V02.XX:

#Pri = 0_*.*

#Pri = *.*


#Pri

#InpPri

Параметр задает маску и имя подкаталога для раскладки принимаемых файлов по папкам. Имя подкаталога добавляется к папке, заданной параметром #Inp. Например, файл с именем 0_file.txt будет принят в папку C:\TCFOSS\INP\Pri0, файл с именем 1_file.txt в C:\TCFOSS\INP\Pri1, а файл с именем 2_file.txt в C:\TCFOSS\INP, если в файле конфигурации будет задано:

#Inp = C:\TCPFOSS\INP

#InpPri = Pri0\0_*.*

#InpPri = Pri1\1_*.*

Параметр введен в версии 4.5.19 и отсутствует у клиентской версии программы TcpFoss. Можно задать до восьми масок. Если параметр не задан, то все файлы будут приниматься в папку, заданную параметром #Inp.


#Scan

#Scan

Параметр определяет интервал между проверками выходного почтового ящика абонента (в секундах). При обнаружении в почтовом ящике файла, он будет передан абоненту. Начиная с V03.08, этот параметр может быть равным нулю или отрицательным. Если параметр равен нулю, то обмен с абонентом проводится один раз. После проведения обмена со всеми такими абонентами программа завершает свою работу. Отрицательное значение запрещает автоматический выход на связь. В этом случае обмен с абонентом происходит только по команде оператора.

По умолчанию используется значение параметра #Scan, указанное в файле до первого появления параметра #Host

Этот параметр отсутствует у клиентской версии программы TCPFoss.

#Scan = 10


#ReScan

#ReScan

С помощью этого параметра можно организовать обмен файлами их обработку и получение результатов обработки за один сеанс связи. При ненулевом значении параметра после обмена файлами канал связи не закрывается. Вместо этого делается пауза, повторный обмен и уже затем канал связи закрывается. Параметр задает длительность паузы в секундах.

Параметр введен в версии V04.03.11. Значение по умолчанию - 0.

#ReScan = 0


#Polling

#Polling

Параметр определяет интервал выхода на связь с абонентом, независимо от наличия для него файлов на передачу (в сек). Интервал отсчитывается с момента окончания последнего обмена. Начиная с версии V03.08, параметр может быть равным нулю или отрицательным. Если параметр равен нулю, то выход на связь при пустом выходном ящике не производится. Если параметр отрицателен, то при старте программы не делается проверочное соединение.

По умолчанию используется значение параметра #Polling, указанное в файле до первого появления параметра #Host

Этот параметр отсутствует у клиентской версии программы TCPFoss.

#Polling = 20


#RasPhone, #RasPhone_N

#RasPhone, #RasPhone_N

Параметр задает номер телефона для установки соединения с помощью удаленного доступа. Если параметр опущен, то телефон берется из телефонной книги удаленного доступа. Параметр #RasPhone задает телефон для соединения Name, параметр #RasPhone_1 - для соединения Name_1 и т.д., где Name - имя абонента.

Параметр введен в версии V3.14.

#RasPhone = 123-456


#RasPsw

#RasPsw

Параметр задает пароль для установки соединения с помощью удаленного доступа. Если параметр опущен, то пароль берется из телефонной книги удаленного доступа. (Внимание: NT 3.51 не сохраняет пароль в телефонной книге).

Параметр введен в версии V3.08.

#RasPsw = "My Password"


#RasPsw_N

#RasPsw_N

Начиная с версии V03.13 можно для разных телефонов, задавать различные пароли. Например, для абонента UUUU в удаленном доступе заведено четыре соединения с именами UUUU, UUUU_1, UUUU_3, UUUU_5, а в файле конфигурации записано:

#RasPsw=Psw

#RasPsw_1=Psw1

#RasPsw_5=Psw5

При этом для соединений UUUU, UUUU_3 будет использоваться пароль Psw, для соединения UUUU_1 - Psw1, а для UUUU_5 - Psw5.


#RasUser

#RasUser

Параметр задает имя пользователя для установки соединения с помощью удаленного доступа. По умолчанию имя пользователя считывается из телефонной книги удаленного доступа. При работе с NT3.51 по умолчанию в качестве имени пользователя берется значения параметра #Name.

Параметр введен с версии V03.10.

#RasUser = User


#RasUser_N

#RasUser_N

Начиная с версии V03.13 можно для разных телефонов, задавать различные имена пользователей. Например, для абонента UUUU в удаленном доступе заведено четыре соединения с именами UUUU, UUUU_1, UUUU_3, UUUU_5, а в файле конфигурации записано:

#RasUser=User

#RasUser_1=User1

#RasUser_5=User5

При этом для соединений UUUU, UUUU_3 будет установлено имя пользователя User, для соединения UUUU_1 - User1, а для UUUU_5 - User5.


#RasDomain

#RasDomain

Параметр задает домен для установки соединения с помощью удаленного доступа. По умолчанию имя домена считывается из телефонной книги удаленного доступа.

Параметр введен с версии V03.13.

#RasDomain = User


#RasDomain_N

#RasDomain_N

Начиная с версии V03.13 можно для разных телефонов, задавать различные имена доменов. Например, для абонента UUUU в удаленном доступе заведено четыре соединения с именами UUUU, UUUU_1, UUUU_3, UUUU_5, а в файле конфигурации записано:

#RasDomain=Domain

#RasDomain_1=Domain1

#RasDomain_5=Domain5

При этом для соединений UUUU, UUUU_3 будет установлено имя домена Domain, для соединения UUUU_1 - Domain1, а для UUUU_5 - Domain5.


#RasConn, #RasConn_N

#RasConn, #RasConn_N

Начиная с V04.03.8 можно переопределять имена соединений используемых TCPFoss для дозвона. Если ни один параметр не указан, то в качестве имен соединений используются строки Name, Nаme_1, ..., Name_9, где Name - имя абонента.

#RasConn = "Подключение удаленного доступа к сети"


#AddRoute

#AddRoute

Параметр введен в версии V04.03.2. С его помощью отпадает необходимость в использовании dial-up соединения в качестве маршрутизатора по умолчанию. При ненулевом значении параметра, после установки соединения, автоматически добавляется маршрут: для ip адреса абонента все пакеты идут через dial-up соединение. По умолчанию используется значение параметра #AddRoute указанное в файле до первого появления параметра или 0.

#AddRoute = 0


#RasPause

#RasPause

Параметр определяет, через какой промежуток времени делать повторную попытку установки соединения, в случае если предыдущая попытка была неудачной. Начиная с версии V03.08 можно не делать повторных попыток выхода на связь, задав отрицательное значение параметра. По умолчанию используется значение параметра #RasPause, указанное в файле до первого появления параметра #Host или 2 сек.

#RasPause = 2


#Break

#Break

Параметр задает интервал времени (в секундах), в течение которого, можно устанавливать связь с абонентом. Если интервал истечет, абонент считается неисправным, попытки вызова прекращаются на интервал #BreakPause. Для абонентов, которые сами должны выходить на связь (см. Параметр #Host, тип КС="*"), этот параметр интерпретируется, как интервал времени, в течение которого, абонент должен выйти на связь. По умолчанию используется значение параметра #Break, указанное в файле до первого появления параметра #Host или 60 сек. Если значение параметра меньше 0, все проверки отключаются.

#Break = 60


#BreakPause

#BreakPause

Параметр задает паузу между неуспешными вызовами абонента, в сек. Если значение параметра отрицательно, то повторных вызовов не делается. По умолчанию используется значение параметра #BreakPause указанное в файле до первого появления параметра #Host или 0 сек.

#BreakPause = 0


#TcpClosePause

#TcpClosePause

Параметр задает паузу между закрытием TCP соединения и разрывом модемного соединения. Параметр введен в версии V03.10 для устранения выдачи ложного сообщения "Обмен прерван". По умолчанию используется значение параметра #TcpClosePause указанное в файле до первого появления параметра #Host или 4 сек.

#TcpClosePause = 4


#Auten

#Auten

С помощью данного параметра можно управлять аутентификацией индивидуально, для каждого абонента. Нулевое значение параметра выключает аутентификацию при установке связи с абонентом. Единичное значение параметра включает аутентификацию FOSS. Двойка - включает аутентификацию НБУ. По умолчанию используется значение параметра #Auten указанное в файле до первого появления параметра #Host или 1, если в файле конфигурации заданы параметры #Private и #Public , и 0, в остальных случаях.

Параметр появился в версии V03.11. В качестве возможных значений можно было использовать 0 и 1. Начиная с версии V04.00 можно использовать значения 0, 1 и 2. Более подробно об аутентификации сказано в разделе Аутентификация абонентов.

#Auten = 1


#TimeOut

#TimeOut

Параметр задает интервал времени, по истечении которого соединение с абонентом будет разорвано, если за это время ничего не удалось отправить или принять. По умолчанию используется значение параметра #TimeOut указанное в файле до первого появления параметра #Host или 60 сек.

#TimeOut = 60


#ConnectTimeOut

#ConnectTimeOut

Параметр задает максимальный интервал времени, отведенный на установку TCP соединения с абонентом. По умолчанию используется значение параметра #ConnectTimeOut указанное в файле до первого появления параметра #Host или 60 сек.

#ConnectTimeOut = 60


#DebugInp

#DebugInp

Параметр введен в версии V03.13 для отладочных целей. Он задает имя папки, в которую будет производиться прием файла параллельно с приемом в папку #Inp\TMP.

Символ # в имени папки заменяется именем абонента.

По умолчанию параллельный прием не ведется.

#DebugInp = C:\ TCPFoss\#\DbgInp


#RasTimeOut

#RasTimeOut

Параметр введен в версии V03.16, для ограничения времени установки соединения с помощью удаленного доступа. Время задается в секундах, и по умолчанию равно 300 секунд.

#RasTimeOut = 300


#SoundErr

#SoundErr

Параметр задает имя звукового файла, который будет проигран при наступлении событий типа "Абонент не выходит на связь", "Абонент не отвечает". Параметр введен в версии V03.13.

#SoundErr = C:\ TCPFoss\ding.wav


#SoundErrTimeOut

#SoundErrTimeOut

Параметр введен в версии V03.16, для указания минимального интервала между повторным проигрыванием звукового файла, заданного параметром #SoundErr, при появлении одного и того же события. Интервал задается в секундах, и по умолчанию равен 300 секунд.

#SoundErrTimeOut = 300


#BeepErr

#BeepErr

Параметр введен в версии V4.5.9 и задает частоту (Гц), длительность звукового сигнала (мс), и длительность паузы (мс). Сигнал будет воспроизведен на динамике компьютера при наступлении событий типа "Абонент не выходит на связь", "Абонент не отвечает". Можно указывать несколько частот.

#BeepErr = 1000,200,300, 2000,400,0

В этом примере задается сигнал с частотой 1000 Гц длительностью 200 мс, после паузы в 300 мс, частота 2000 Гц, длительность 400 мс.


#NbuCrypto

#NbuCrypto

Параметр задает маску файлов, которые должны шифроваться при передаче. При указании параметра в файле конфигурации исходящие файлы шифруются независимо от того, указан он или нет у получателя. При получении зашифрованных файлов они расшифровываются независимо от того, указан он или нет у получателя. Параметр введен в версии V04.02.

Шифрование будет производиться только при включенной аутентификации НБУ. Если параметр опущен, то файлы шифроваться не будут. По умолчанию используется значение параметра указанное до первого появления параметра #Host. Можно указать несколько масок файлов. Например:

#NbuCrypto = 0_*.*

#NbuCrypto = *.sec


#NbuMac

#NbuMac

Параметр задает маску файлов, которые должны подписываться при передаче. При указании параметра в файле конфигурации исходящие файлы подписываются независимо от того, указан он или нет у получателя. При получении подписанных файлов подпись проверяется независимо от того, указан он или нет у получателя. Параметр введен в версии V4.5.0. Подпись файлов будет производиться только при включенной аутентификации НБУ. Файлы не подписываются, если они должны шифроваться или параметр опущен.

По умолчанию используется значение параметра указанное до первого появления параметра #Host. Можно указать несколько масок файлов. Например:

#NbuMac = 0_*.*

#NbuMac = *.sec


#MaxTxCps

#MaxTxCps

Параметр задает максимальную скорость передачи в байтах за секунду. Если параметр равен 0, то скорость передачи не ограничивается.

Параметр введен в версии V03.19. Значение по умолчанию 0.

#MaxTxCps = 0


#MaxRxCps

#MaxRxCps

Параметр задает максимальную скорость приема в байтах за секунду. Если параметр равен 0, то скорость приема не ограничивается.

Параметр введен в версии V03.19. Значение по умолчанию 0.

#MaxRxCps = 0


#Compress

#Compress

Параметр задает маску для файлов, которые необходимо сжимать во время передачи. При приеме сжатые файлы распаковываются автоматически. Можно задать несколько масок. Параметр введен в версии V3.20.

#Compress = *.doc

#Compress = *.txt


#NoCompress

#NoCompress

Параметр задает маску для файлов, которые не надо сжимать при передаче. Параметр введен в версии V3.20. Следующие строки указывают сжимать все файлы кроме *.zip и *.arj

#NoCompress = *.zip

#NoCompress = *.arj

#Compress = *.*


#Comment

#Comment

Параметр задает комментарий, который будет отображаться в главном окне программу, сразу за именем абонента. Параметр введен в версии V03.20.

#Comment = "VIP клиент"


#LanTry

#LanTry

Параметр задает число попыток связаться с абонентом по локальной сети, перед тем как начинать использовать модем. Параметр удобен для организации резервного канала связи при пропадании основного, организованного через маршрутизатор в локальной сети.

Параметр введен в версии V04.03. Значение по умолчанию 0. Если для связи с абонентом модем не нужен, параметр не оказывает никакого влияния.

#LanTry = 0


#ConnectRetry

#ConnectRetry

Параметр задает число попыток связаться с абонентом, перед тем как положить трубку, либо перед переходом к использованию другого канала связи. Параметр введен в версии V04.03.9. Значение по умолчанию 1.

#ConnectRetry = 1


#ConnectEvent

#ConnectEvent

Параметр задает имя Event объекта, который устанавливается после установки соединения с абонентом перед началом обмена. Event объект можно использовать во внешней программе, например так:

HANDLE hEvent = CreateEvent(NULL,FALSE,FALSE,"UUUU_Connect");

DWORD dwRet = WaitForSingleObject(hEvent,INFINITE);

#ConnectEvent = UUUU_Connect


#DisconnectEvent

#DisconnectEvent

Параметр задает имя Event объекта, который устанавливается после окончания обмена с абонентом. Event объект можно использовать во внешней программе, например так:

HANDLE hEvent = CreateEvent(NULL,FALSE,FALSE,"UUUU_Connect");

DWORD dwRet = WaitForSingleObject(hEvent,INFINITE);

#DisconnectEvent = UUUU_Disconnect.


#LanAddr

#LanAddr

ПараметрзадаетIP адресабонентаприобменеполокальнойсети. При этом IP адреса заданные в параметре не используются. При необходимости можно задать несколько адресов:

#LanAddr = 200.0.0.1

#LanAddr = 200.0.1.2

Параметр введен в версии 4.5.8.


#RasAddr

#RasAddr

Параметр задает IP адрес абонента при обмене через модем. При этом IP адреса заданные в параметре не используются. При необходимости можно задать несколько адресов:

#RasAddr = 200.0.0.1

#RasAddr = 200.0.1.2

Параметр введен в версии 4.5.8.


#RasAddr_N

#RasAddr_N

Параметр задает IP адрес абонента при обмене через модем для конкретной записи в удаленном доступе. При этом IP адреса заданные в параметре не используются. При необходимости можно задать несколько адресов:

#RasAddr_1 = 200.0.0.1

#RasAddr_1 = 200.0.1.2

#RasAddr_2 = 200.0.0.1

Параметр введен в версии 4.5.8.


#CheckTime

#CheckTime

При допередаче файлов проверяется контрольная сумма переданной части файла, и, в зависимости от значения параметра, время создания или модификации файла. Если параметр равен 2, то проверяется время модификации, 1 – время создания, 0 – время не проверяется. Значение по умолчанию 2.

#CheckTime = 2

Параметр добавлен в версии 4.5.15.


#ReScan

#Bind

С помощью этого параметра можно привязать TCP сокет к сетевой карте. Это полезно при наличии нескольких сетевых карт, установленных в компьютере.

Для привязки клиентского сокета к IP адресу сетевой карты, необходимо объявить параметр #Bind после параметра #Host.

Для привязки сервера к ip адресу сетевой карты необходимо объявить параметр #Bind до первого появления параметра #Host. В этом случае, по умолчанию, все клиентские сокеты будут привязаны к этой же сетевой карте.

Параметр введен в версии V04.6.4.

#Bind = 192.10.20.30


Настройка операционной системы

Настройка операционной системы

Работоспособность программы TCPFoss проверялась со следующими операционными системами Windows 95, Windows 95 OSR2, Windows NT 3.51, Windows NT 4.0, Windows 98, Windows ME, Windows 2000, Windows XP, Windows Vista.

Операционные системы накладывают следующие ограничения при работе с модемами:

  • Windows 95 не позволяет использовать более одного модемного соединения одновременно. Т.е. Вы не можете установить два исходящих соединения или одно входящее, а другое исходящее соединение. (См. Настройка Windows 95).
  • Windows NT Workstation допускает использовать только один модем для входящих звонков и несколько для исходящих. (См. Настройка Windows NT).
  • Windows NT Server не имеет никаких ограничений.

Настройки для Windows 98, Windows ME, Windows 2000, Windows XP, делаются аналогично. Дополнительную информацию можно получить, запустив справочную систему Windows (Пуск-Справка) и набрав в строке для поиска "удаленный доступ к сети".


Настройка Windows для работы с TCPFoss

Настройка Windows 95 для работы с TCPFoss

Для настройки Windows 95 необходимо выполнить следующие действия:

1. Установить удаленный доступ к сети.

2. Установить протокол TCP/IP.

3. Установить Сервер удаленного доступа, если данный компьютер будет обслуживать входящие телефонные звонки.

4. Создать соединения для подключения к абонентам.


Установка удаленного доступа к сети

Установка удаленного доступа к сети

1. В "Панели управления" откройте окно "Установка и удаление программ" и выберите там закладку "Установка Windows".

2. На этой закладке найдите компонент "Связь", выделите его имя и нажмите кнопку "Состав".

3. Поставьте галочку против составляющей "Удаленный доступ к сети" и нажмите кнопку "ОК".

4. Снова нажмите кнопку "ОК".

5. В "Панели управления" откройте окно "Сеть", найдите там "Контроллер удаленного доступа" и перейдите к шагу 10.

6. Если контроллер удаленного доступа не найден нажмите кнопку "Добавить".

7. Выберите в списке пункт "Сетевая плата" и нажмите кнопку "Добавить".

8. В списке производителей выберите Microsoft, а в списке сетевых плат "Контроллер удаленного доступа".

9. Нажмите кнопку "ОК".

10. Еще раз нажмите кнопку "ОК" или перейдите к установке протокола TCP/IP.Ip95


Установка протокола TCP/IP

Установка протокола TCP/IP

1. В "Панели управления" откройте окно "Сеть" и нажмите кнопку "Добавить".

2. Выберите в списке пункт "Протокол" и нажмите кнопку "Добавить".

3. В списке производителей выберите Microsoft, а в списке сетевых протоколов TCP/IP.

4. Нажмите кнопку "OK".

5. Удалите все протоколы, связанные с "Контроллером удаленного доступа", кроме TCP/IP.

6. Удалите протокол TCP/IP связанный с другими сетевыми устройствами, кроме "Контроллера удаленного доступа", если он Вам не нужен.

7. Выберите в списке протокол TCP/IP, связанный с "Контроллером удаленного доступа" и нажмите кнопку "Свойства".

8. Выберите закладку "Привязка" и уберите галочки против всех компонентов сети, кроме "Клиент для сетей Microsoft". Эти действия запретят использовать протокол TCP/IP для доступа к файлам на Вашем компьютере.

9. Если Вы планируете устанавливать на этом компьютере "Сервер удаленного доступа", то выберите закладку "Адрес IP" и введите на ней IP адрес и маску подсети, например адрес 200.0.0.1, маска 255.255.255.0. IP адрес будут вводить Ваши клиенты в параметре #Host

10. Нажмите кнопку "ОК".

11. Снова нажмите кнопку "OK".


Установка сервера удаленного доступа

Установка сервера удаленного доступа

1. Установите компакт диск с "Microsoft Plus for Windows 95" и запустите программу setup.exe.

2. Нажмите кнопку Add/Remove.

3. В списке "Options" поставьте галочку против "Dial-Up Networking Server" и нажмите кнопку "Continue".


Создание соединений для подключения к абонентам

Создание соединений для подключения к абонентам

1. В "Мой компьютер" откройте папку "Удаленный доступ к сети".

2. Дважды щелкните значок "Новое соединение".

3. В качестве имени соединения укажите имя абонента. Примечание: имя абонента задается параметром #Host

4. Выберите модем и нажмите кнопку "Далее".

5. Введите номер телефона абонента и нажмите кнопку "Далее".

6. Нажмите кнопку "Готово".

7. В папке "Удаленный доступ к сети" выделите вновь созданной соединение и выберите команду "Свойства" в меню файл.

8. Выберите закладку "Тип сервера".

9. Уберите галочки против "Войти в сеть", "NetBEUI" и "IPX/SPX-совместимый".

10. Нажмите кнопку "Настройка TCP/IP".

11. Узнайте у администратора узла, к которому Вы будете подключаться IP адрес для соединения и введите его в поле "Адрес IP". Обычно для узла на базе NT можно оставить выбранным "Адрес IP назначается сервером". Для узла на базе Windows 95 адрес обязательно вводится вручную и он должен находиться в той же подсети что и адрес, заданный при установке "Сервера удаленного доступа", например 200.0.0.2, если у "Сервера удаленного доступа адрес" 200.0.0.1.

12. Два раза нажмите кнопку "ОК".

13. Два раза щелкните по созданному соединению, введите "Имя пользователя" и "Пароль" (узнайте эти параметры у администратора узла), поставьте галочку против "Сохранить пароль" и нажмите кнопку "Установить связь".

14. Добейтесь успешной установки соединения с удаленным узлом, т.к. только после этого имя пользователя и пароль будут запомнены Windows 95.

15. Если к абоненту можно дозвониться по нескольким телефонам, повторите шаги 2-14, добавив на шаге 3 к имени абонента символ подчеркивания и цифру (исключая ноль). Например, если Вы создали соединение с именем U0H0, то второе соединение будет иметь имя U0H0_1, третье U0H0_2, десятое U0H0_9.


Настройка Windows NT для работы с TCPFoss

Настройка Windows NT для работы с TCPFoss

Для настройки Windows NT необходимо выполнить следующие действия:

1. Установить протокол TCP/IP.

2. Установить сервер удаленного доступа (RAS).

3. Создать соединения для подключения к абонентам.


Установка протокола TCP/IP

Установка протокола TCP/IP

1. В "Control Panel" откройте окно "Network" и выберите в нем закладку "Protocols".

2. Если в списке "Network Protoсols" отсутствует "TCP/IP Protocol", то нажмите кнопку "Add...", иначе выделите строку "TCP/IP Protocol", нажмите кнопку "Properties..." и перейдите к шагу 7.

3. В списке "Network Protocol" выберите "TCP/IP Protocol" и нажмите кнопку "ОК".

4. Ответьте "No" на вопрос о наличии DHSP сервера.

5. Введите местоположение инсталляции NT и нажмите кнопку "Continue"

6. Нажмите кнопку "Close".

7. Введите IP адрес (IP address) и маску подсети (Subnet Mask) для сетевой карты, установленной в компьютере. Сообщите этот адрес Вашим абонентам (клиентам), чтобы они ввели его при настройке параметра #Host для Вашего узла.

8. Нажмите кнопку "OK" и ответьте "Yes" на вопрос о перезагрузке компьютера.


Установка Сервера удаленного доступа

Установка Сервера удаленного доступа

1. В "Control Panel" откройте окно "Network" и выберите в нем закладку "Services"

2. Если в списке "Network Services" отсутствует "Remote Access Service", то нажмите кнопку "Add...", иначе перейдите к шагу 4.

3. Всписке "Network Service" выберите "Remote Access Service" инажмитекнопку "ОК".

4. Введите местоположение инсталляции NT и нажмите кнопку "Continue"

5. Если у Вас нет установленных модемов, то система предложит Вам добавить модем.

Иначе выберите модем, который будет использоваться для связи в поле "Ras Capable Devices" и нажмите кнопку "OK".

6. Настройте модем, нажав кнопку "Configure..." и выбрав одно из трех назначений модема: только для исходящих звонков (dial out only), только для входящих звонков (receive calls only) или как для входящих, так и для исходящих звонков (Dial out and Receive calls) и нажмите кнопку "ОК".

Выбирайте "Dial out only" если Вы будете только звонить абоненту и не планируете обслуживать входящие звонки.

Примечание: NT Workstation позволяет настроить только один модем для приема входящих звонков.

7. При наличии нескольких модемов нажмите кнопку "Add..." и повторите шаги 5 и 6.

8. Нажмите кнопку Network и установите галочку против протокола TCP/IP и уберите для остальных протоколов.

При наличии хотя бы одного модема настроенного для приема входящих звонков дополнительно потребуется задать "Service setting", а именно установить галочку против протокола TCP/IP и уберите для остальных протоколов

Затем нажмите кнопку "Configure..." напротив "TCP/IP". Запретите маршрутизацию IP пакетов в локальную сеть (если это конечно нужно), выбрав пункт "This computer only", разрешите использовать статический пул адресов для назначения адресов Вашим удаленным клиентам, выбрав пункт "Use static adderess pool". Заполните поле "Begin" и "End", введя начальный и конечный адрес. Чтобы не было проблем с маршрутизацией, пул адресов выделяйте в вашей подсетке адресов. Например, Ваша подсетка адресов имеет маску 255.255.255.0 и компьютеры в Вашей локальной сети занимают адреса от 200.0.0.1 до 200.0.0.100. Введите в поле "Begin" адрес 200.0.0.101, а в поле End "200.0.0.254".

Можно также разрешить абонентам самим задавать свой адрес, а не получать его из пула адресов, поставив галочку против "Allow remote clients request predeterminate IP address". Выберите IP адрес в своей подсетке адресов и сообщите его вашему клиенту.

Примечание: Если при создании соединения в удаленном доступе к сети клиент установит предопределенный адрес, а у Вас это действие будет запрещено, то возможны ситуации когда клиент не сможет установить соединение (Ошибка: не найден совместимый протокол) или соединение установится, но обмен идти не будет.

Сообщите также адрес вашей сетевой карты или адрес, указанный в поле Begin. Клиент укажет этот адрес в параметре #Host при описании Вашего узла.

9. Нажмите кнопку "OK".

10. Еще раз нажмите "OK".

11. Нажмите кнопку "Continue"

12. Нажмите кнопку "OK" при появлении сообщения

13. Нажмите кнопку "Close"

14. Нажмите кнопку "OK" при запросе IP адреса для сетевой платы

15. Ответьте "Yes" на вопрос о перезагрузке компьютера

16. Если Вы предполагаете использовать компьютер для обслуживания удаленных клиентов, то после перезагрузки запустите User manager и создайте нового пользователя для каждого клиента. Задайте его пароль и права.

17. Затем нажмите на кнопку "Dialin" и дайте этому пользователю право на подключение к Вашему компьютеру через модем, установив галочку против "Grand dialin permission to user". Затем нажмите кнопку "OK"

Примечания:

1. Право на подключение через модем можно также установить с помощью "Remote Access Admin" командой Permissions... в меню Users:

2. User Manager и Remote Access Admin находятсяменю "Start" , папка "Programs" группа "Administrative Tools (Common)".


Создание соединений для подключения к абонентам

Создание соединений для подключения к абонентам

1. В "My computer" откройтепапку "Dial-Up Networking". Если телефонная книга пуста, Вы получите сообщение:

Нажмите кнопку "ОК" для продолжения.

Поставьте галочку против "I know all...", введите имя абонента в качестве "Name the new phonebook entry" и нажмите кнопку "Finish". Примечание: имя абонента определяет параметр #Host в файле конфигурации TCPFoss.

Если в телефонной книге были записи, то Вы получите следующую форму:

Нажмите кнопку "New...".

2. Введите имя абонента в поле "Entry name", наберите номер телефона в поле "Phone number", выберите модем поле "Dial using", уберите галочку против "Use another port if busy" и перейдите к закладке "Server".

3. В поле "Dial-up server type" выберите "PPP: Windows NT, Windows 95 Plus, Internet", поставьте галочку против "TCP/IP" и уберите против "IPX/SPX compatible" и "NetBEUI".

4. Если узел, к которому Вы подключаетесь, не назначает IP адреса автоматически, нажмите кнопку "TCP/IP Settings..." , введите IP адрес, выданный администратором узла, и нажмите кнопку "ОК".

5. Нажмите кнопку "ОК", а затем "Dial".

6. Заполните поля "User name", "Password" и "Domain" (значение этих полей определяет администратор узла, к которому Вы будете подключаться"), поставьте галочку против "Save password" и нажмите кнопку "OK".

7. Добейтесь успешной установки соединения с удаленным узлом, т.к. только после этого имя пользователя и пароль будут запомнены Windows NT.

8. Если к абоненту можно дозвониться по нескольким телефонам, повторите шаги 2-8, добавив на шаге 2 к имени абонента символ подчеркивания и цифру (исключая ноль). Например, если Вы создали соединение с именем U0H0, то второе соединение будет иметь имя U0H0_1, третье U0H0_2, десятое U0H0_9.


Запуск и работа с программой

Запуск и работа с программой

Командная строка для запуска программы:

TCPFoss [file.tcp] [/NoSplash] [/Min] [/Max] [/tray]

где file.tcp - имя файла конфигурации (по умолчанию используется TCPFoss.tcp),

/NoSplash - ключ для отключения splash окна,

/Min - ключ для запуска программы в минимизированном окне,

/Max - ключ для запуска программы в максимизированном окне,

/tray - запуск программы, свернутой в трей.

Формат файла конфигурации описан в разделе "Настройка программы"

Возможно появление сообщений об ошибках при наличии ошибок в файле конфигурации.

После запуска программы на экране появляется окно, отображающее состояние всех абонентов, описанных в файле конфигурации параметром #Host.

Главное окно клиент/серверной версии программы:

Главное окно клиентской версии программы:

Каждый абонент может находиться в одном из состояний:

  • Отключен - В этом состоянии абонент находится после запуска программы.
  • Вызов абонента - Идет установка TCP/IP соединения с абонентом.
  • Аутентификация - Идет аутентификация абонента.
  • Передача сертификата - Идет передача своего сертификата открытого ключа (При включенной аутентификации НБУ)
  • Занят – Вызов абонента завершился неудачно, т.к. у абонента нет свободных каналов.
  • Не отвечает – TCP/IP соединение не установлено. Скорее всего, у абонента не загружена программа ТCPFOSS, нет канала связи или задан неверный IP адрес абонента. Проверьте канал связи и адрес утилитой PING.
  • Обмен - Идет обмен файлами с абонентом. Открыв окно с подробной информацией, можно посмотреть какие файлы передаются и принимаются.
  • Обмен окончен - Успешное завершение обмена.
  • Обмен окончен - Тоже, что и в предыдущем случае, но при проведении обмена возникали ошибки ввода вывода (например, при отсутствии места на диске).
  • Обмен прерван – Обмен может прервать оператор, выгрузив программу TCPFoss или, выполнив команду "Остановить" в меню "Абонент". Кроме того, обмен может прерваться из-за обрыва канала связи.
  • Обмен прерван – Тоже, что и в предыдущем случае, но при проведении обмена возникали ошибки ввода вывода (например, при отсутствии места на диске).
  • Установка канала связи - Идет установка удаленного доступа к сети.
  • Канал связи не установлен - Удаленный доступ к сети не был установлен.
  • Вызов остановлен - Оператор выполнил команду "Остановить" в меню "Абонент".
  • Отказал в доступе - Абонент отказал в доступе, например из-за того, что у него включена аутентификация абонентов (см. параметры #Private и #Public в файле конфигурации), а на данном узле нет.
  • Отказано в доступе - Данному абоненту отказано в доступе, например из-за неверного ключа доступа к данному узлу.
  • Нет протокола у абонента – Абонент не может открыть файл протокола. Обмен файлами при этом не производится.
  • Нет протокола для абонента – На данном узле для абонента невозможно открыть файл протокола. Обмен файлами при этом не производится.
  • Неверно указан адрес или имя абонента – Вместо требуемого абонента ответил абонент с другим именем.
  • Абонент не выходит на связь - В течение времени указанному в параметре #Break абонент не выходил на связь.
  • Неизвестный абонент - Абонент не зарегистрирован на данном узле.
  • Получен неизвестный пакет - От абонента принят пакет неизвестного типа. На узел вышли другой программой или была попытка взлома программы.
  • Получен END неизвестного типа - Сообщите об этом разработчику.
  • Получен искаженный пакет - Сообщите об этом разработчику.
  • Переполнение выходного буфера - Сообщите об этом разработчику.

Программа работает следующим образом. С интервалом, задаваемым параметром #Scan производится сканирование выходных ящиков абонентов. Путь к ящику определяет параметр #Out. При обнаружении в ящике файлов, программа устанавливается соединение с абонентом и передает обнаруженные файлы. Одновременно с передачей производится прием файлов из своего удаленного выходного почтового ящика в папку, заданную параметром #Inp

Соединение с абонентом устанавливается и в случае отсутствия файлов в выходном ящике по истечению интервала, задаваемого параметром #Polling для приема файлов.

Передача файлов ведется с учетом их приоритетов. Передача низкоприоритетных файлов прерывается с появлением высокоприоритетных.

Все сообщения о передаче и приеме файлов записываются в файле протокола и выводятся в окно с подробной информацией.

Замечания:

  • В окне с подробной информацией выводятся последние #LogRows строк.
  • Формат файла протокола описан в разделе Файл протокола.

Основное окно имеет следующие меню:

Меню "Файл"

Содержит команды:

  • Открыть - Загрузить новый файл конфигурации. При открытии нового файла конфигурации работа со старым файлом прекращается, установленные соединения разрываются.
  • Свойства - Открыть текущий файл конфигурации в редакторе notepad. По окончанию редактирования, измененный файл конфигурации автоматически перезагружается.
  • Перезагрузка - Перезагрузить текущий файл конфигурации.
  • Выход - Завершить работу с программой. При завершении программы разрываются все установленные соединения. Команда может быть заблокирована с помощью параметра #CanClose.

Меню "Абонент"

Содержит команды:

  • Открыть - Открыть окно с подробной информацией о передаваемых и принимаемых файлах. То же самое можно сделать, два раза щелкнув левой кнопкой мыши по имени абонента. В клиентской версии программы эта информация отображается в главном окне.

  • Статистика - Открыть окно с информацией о количестве принятых и переданных файлов

  • Вызвать - Выйти на связь с абонентом. Эта команда заблокирована, если при описании абонента параметром #Host было указано что абонент сам выходит на связь.
  • Остановить - Остановить вызов абонента. Обмен с абонентом прекращается и больше не делается попыток выйти на связь. Команда "Вызвать" отменяет действие команды "Остановить". Команда заблокирована, если при описании абонента параметром #Host было указано что абонент сам выходит на связь.

Примечание:

Меню "Абонент" можно вызвать щелчком правой кнопки мыши по имени абонента.

Меню "Вид"

Содержит команды:

  • Панель инструментов - Включить или выключить панель инструментов.
  • Строка состояния - Включить или выключить строку состояния.
  • Сворачивать в трей - Сворачивать программу в трей, вместо панели задач.

Меню ?

Содержит команды:

  • Вызов справки.
  • О TCPFoss - Получить информацию о версии программы.

При завершении программы создается файл с именем TCPFoss.ini, содержащим текущее положение, размеры окна, строка состояния и т.д. и устанавливает один из кодов возврата:

  • 0 - OK. Если программа настроена на автоматическое завершение после обмена со всеми абонентами (#Scan=0), это значит, что обмен со всеми прошел нормально. Для #Scan = 0, это значит, что программу завершил оператор.
  • 1 - Программу завершил оператор в конфигурации #Scan=0.
  • 2 - Ошибка в файле конфигурации.
  • 3 - Не все файлы были переданы абонентам.


Аутентификация

Аутентификация

Аутентификация абонентов может производиться тремя способами:

  • На основе имени абонента и его серийного номера;
  • С помощью RSA ключей, генерируемых программой TCPCL;
  • С помощью RSA ключей, генерируемых с использованием программ НБУ.

С помощью параметра #Auten для каждого абонента можно задать свой способ аутентификации.

Аутентификация на основе имени абонента и его серийного номера

Для задания этого режима необходимо установить значения параметра #Auten=0.

Аутентификация помощью RSA ключей, генерируемых программой TCPCL

В этом режиме аутентификация производится следующим образом:

  • Абонент X формирует случайную строку S, шифрует ее открытым ключом абонента Y и полученный результат (строку Sy) передает абоненту Y.
  • Абонент Y расшифровывает строку Sy своим закрытым ключом, шифрует результат открытым ключом абонента X и передает результат (строку Sx) абоненту X.
  • Абонент X расшифровывает строку Sx своим закрытым ключом. Если полученный результат совпадает со строкой S, то абонент Х готов к обмену с абонентом Y, иначе он отказывает в доступе абоненту Y.
  • Аналогичные действия выполняет и абонент Y по отношению к абоненту X.

Для задания этого режима необходимо установить значение параметра #Auten=1, параметр #Public должен указывать на файл с открытыми ключами FOSS, параметр #Private должен указывать на файл с закрытым ключом данного узла.

Аутентификация помощью RSA ключей, генерируемых с помощью программ НБУ

Для задания этого режима необходимо установить значение параметра #Auten=2. Параметр #NbuPublic должен указывать на папку, в которой будут храниться открытые ключи абонентов. Параметр #NbuPrivate должен указывать на устройство, хранящее закрытый ключ данного узла. Параметр #NbuSert на папку, в которую, с помощью внешних программ, будут выкладываться файлы с сертификатами НБУ.

Одним или несколькими параметрами #NbuCrypto можно указать маски файлов, которые будут шифроваться во время передачи.

В этом режиме аутентификация абонентов производится библиотекой защиты НБУ, а TCPFoss занимается только доставкой пакетов, сформированных библиотекой. Всего, может произойти два этапа аутентификации. Если первый этап неудачный, абоненты обмениваются своими действующими сертификатами, встраивают эти сертификаты в таблицы открытых ключей и производят повторную аутентификацию.

В этом режиме в программе появляется дополнительное меню "Защита". При запуске производится инициализация библиотеки НБУ, для чего выводиться диалоговое окно:

Необходимо установить в устройство, заданное параметром #NbuPrivate, закрытый ключ и ввести пароль доступа. При появлении ошибки на экране появляется подобное сообщение:

При этом обмен будет возможен только с абонентами, не использующими аутентификацию НБУ.

Повторить инициализацию можно выбрав в меню "Защита" пункт "Инициализация".

При успешной инициализации пункт "Инициализация" будет недоступен.

В процессе работы программа периодически ищет файл сертификата в папке заданной параметром #NbuSert. При появлении этого файла программа выводит запрос:

Можно отказаться от перехода на новый ключ. Повторно вызвать этот запрос можно командой "Сменить ключ" в меню "Защита".

Если была выбрана смена ключа, сертификат открытого ключа встраивается в таблицу открытых ключей, после чего выводится следующее диалоговое окно:

Появление ошибки при обработке сертификата появляется сообщение:

В зависимости от ошибки полученный сертификат можно удалить (например, если сертификат был испорчен) так и оставить (например, если срок действия ключа не наступил).

Для просмотра действующих ключей служит команда "Просмотр ключа" в меню "Защита":

Если при выполнении команды не был выбран ни один из абонентов, то будет выведена информация о собственном ключе.

Получить общее количество ключей встроенных в таблицу открытых ключей можно с помощью команды "Просмотр ключей" в меню "Защита" и введя маску *.

Возможно, восстановить таблицу открытых ключей из резервной копии. Для этого служит команда "Восстановление ключей" в меню "Защита". Пункт "rsrw.old" восстанавливает ключи из предыдущей копии таблицы открытых ключей, "rsrv.new" - из текущей. После успешного выполнения команды на экран выводится сообщение:

После чего необходимо снова установить в устройство, заданное параметром #NbuPrivate, закрытый ключ и ввести пароль доступа.

При появлении ошибки на экране появляется подобное сообщение:

При неудачной аутентификация абонента его состояние отображается как "Ошибка аутентификации". Более подробную информацию можно получить, установив курсор на этого абонента и выполнив команду "Просмотр ошибки аутентификации" в меню "Защита".


Файл протокола

Файл протокола

Все сообщения о передаче и приеме файлов записываются в файле протокола. Имя файла и путь к нему задает параметр #Log

Файл протокола может записываться в трех форматах:

формат FOSSMAIL (#LogFmt=0);

формат FOSSMAIL без вертикальных разделителей (#LogFmt=1);

формат PROCARRY (#LogFmt=2).

Формат FOSSMAIL содержит следующие поля:

R/S

В этом поле содержится направление передачи и код ошибки. Направление передачи указывается одним из символов:

Символ R - Принят файл.

Символ S - Передан файл.

Наличие символа плюс (+) перед символом направления говорит о допередаче файла. После направления передачи указывается код завершения обмена:

0 - Удачное завершение.

1 - Ошибка открытия передаваемого файла.

2 - Ошибка чтения передаваемого файла.

3 - Ошибка создания принимаемого файла.

4 - Ошибка записи принимаемого файла.

5 - Ошибка при перекладывании принятого файла во входной ящик.

6 - Произошел разрыв канала связи.

7 - Несовпадение контрольных сумм файла на передающей и приемной стороне.

8 - Ошибка чтения файла на приемной стороне при подсчете контрольной суммы.

9 - Передача файла отложена, для передачи более приоритетного файла.

10 - Зарезервирован

11 - Зарезервирован

12 - При шифровании/подписи файла возникла ошибка. Подробная информация содержится в лог файле библиотеки защиты НБУ.

Name file

Поле содержит имя файла.

New name

Если файл при приеме был переименован, то в этом поле отображается новое имя файла.

Date

Поле содержит дату создания файла.

Time

Поле содержит время создания файла.

Length

В этом поле содержится длина файла при удачном завершении обмена или позиция, до которой он был принят/передан при ошибке.

Begin

Поле содержит время начала передачи.

End

Поле содержит время конца передачи.

Cps

Поле содержит скорость передачи файла, байт в сек. Если файл передавался за время меньше секунды, при подсчете скорости принимается время обмена одна секунда.

При установке канала связи в файл протокола записывается строка:

CONNECT N X DDMMYY HH:MM:SS (ABONENT),

где X- количество сеансов связи с абонентом,

ABONENT - имя абонента, с которым установлена связь.

При разрыве канала связи в файл протокола записывается строка:

END CONNECTION DDMMYY HH:MM:SS (S/R N bytes CPS=X),

где N - число переданных/принятых байт,

X - средняя скорость при обмене.

Формат Procarry предусматривает следующие поля:

N

Поле содержит номер канала связи.

Begin

Дата и время начала передачи.

R/S

Поле содержит направление передачи файла:

Строка Recv записывается для принятого файла;

Строка Send записывается для переданных файлов.

Name

Поле содержит имя файла

Len

Поле содержит длину файла

Err

Это поле содержит строку "ОК" при нормальном завершении обмена. При аварийном завершении обмена в это поле записывается позицию, до которой передался файл, а в следующей строке записывается номер канала связи, дата и время возникновения ошибки, строка "Err" и код ошибки. Код ошибки может принимать следующие значения:

1 -Ошибка открытия передаваемого файла.

2 -Ошибка чтения передаваемого файла.

3 -Ошибка создания принимаемого файла.

4 -Ошибка записи принимаемого файла.

5 -Ошибка при перекладывании принятого файла во входной ящик.

6 -Произошел разрыв канала связи.

7 -Несовпадение контрольных сумм файла на передающей и приемной стороне.

8 -Ошибка чтения файла на приемной стороне при подсчете контрольной суммы.

9 -Передача файла отложена, для передачи более приоритетного файла.

10 - Зарезервирован

11 - Зарезервирован

12 - При шифровании/подписи файла возникла ошибка. Подробная информация содержится в лог файле библиотеки защиты НБУ.

Stop

Поле содержит время успешного завершения обмена.

Pos

Поле содержит позицию, до которой принят или передан файл.

Cps

Поле содержит скорость передачи файла, байт в сек. Если файл передавался менее одной секунды, при подсчете скорости за время обмена принимается одна секунда.

При установке канала связи в файл протокола записывается строка:

Session started Name (N X)

где Name - имя абонента, с которым установлена связь

X - количество сеансов связи с этим абонентом.

При разрыве канала связи в файл протокола записывается строка:

CPS: X (N bytes)

где N - число переданных/принятых байт,

X - средняя скорость при обмене.


Сообщения об ошибках

Сообщения об ошибках

Во время чтения файла конфигурации (при старте программы или при выполнении команды [image] Открыть в меню "Файл") оператор может получить следующие сообщения об ошибках:

  • Не найден файл конфигурации - Если путь к файлу конфигурации не указан, то файл конфигурации ищется в текущем рабочем каталоге.
  • Файл конфигурации содержит неизвестный параметр #PP- Проверьте имя параметра.
  • В файле конфигурации пропущен параметр #PP- Параметр PPP является обязательным, поэтому его необходимо добавить в файл конфигурации.
  • Неверный серийный номер программы - Проверьте значение параметра #Serial и #Name
  • Для абонента AAA не найдена папка, заданная параметром #PP-Проверьте наличие соответствующего подкаталога или значение параметра PPP для абонента AAA.
  • Не найдена папка FFF, заданная параметром #PP- Проверьте наличие каталога FFF и значение параметра FFF.
  • Работа в режиме сервера невозможна - Проверьте значение параметра #Port возможно, что указанный порт уже занят другой программой.
  • Не могу прочитать файл с открытыми ключами FFF - Проверьте значение параметра #Public
  • Не могу прочитать файл с закрытым ключом FFF- Проверьте значение параметра #Private
  • Ошибка чтения файла защиты от дубля FFF. Возможно появление дублей у абонента AAA - Файл защиты от дублей оказался испорченным, возможно из-за некорректного выключения компьютера. Файл будет восстановлен автоматически после завершения программы. Тем не менее, у абонента AAA могут появиться (но не обязательно появятся) дубли файлов передаваемых в перед этим запуском программы.
  • Для работы в данной конфигурации необходимо установить удаленный доступ к сети - Программа настроена на использование удаленного доступа (см. #Host), а он не установлен. Требуется установить удаленный доступ к сети.
  • Критическая ошибка в функции CHEK_PROT - SSS - При проверке файла заданного параметром #NbuLog возникла ошибка SSS. Необходимо удалить поврежденный файл, предварительно скопировав его в другую папку для дальнейшего анализа.

При появлении окна с ошибкой оператор, на вопрос "Продолжить?" может нажать кнопку "Да" или "Нет". Кнопка "Да" продолжает разбор файла конфигурации. Кнопка "Нет" - останавливает. В любом случае программа не начинает обмен файлами. Для начала обмена файлами необходимо исправить все ошибки в файле конфигурации, выбрав команду Свойства в меню Файл, либо загрузить другой файл конфигурации командой [image] Открыть из того же меню.


Проблемы и их устранение

Проблемы и их устранение

При работе с программой Вы можете столкнуться со следующими проблемами:

После запуска, сразу же после исчезновения окна заставки, программа аварийно завершается.

Эта ситуация возникает при запорченном файле TCPFoss.ini, который находится в системном подкаталоге Windows. В этом файле содержится информация о положении и размере окон, панели инструментов и т.д. Для устранения проблемы удалите файл TCPFoss.ini, запустите программу и заново настройте размеры и положение окон. В версии V03.13 эта проблема устранена.

Следующая проблема возникает только на Windows NT. Если RAS сервер стартует автоматически и программа TCPFoss уставлена в группе "Автозагрузка" и настроена на работу с модемными каналами связи, то с большой вероятностью после запуска TCPFoss RAS сервер сбрасывает все модемы и перестает работать. Если программу запускать позже, то такая ошибка не возникает. Такая же ситуация возникает и при работе с RRAS.

RAS сервер имеет некоторую "особенность". Если, в течение примерно 15 сек после его запуска, попытаться установить модемное соединение он перестает работать. Чтобы TCPFoss работал в группе "Автозагрузка" добавьте в файл конфигурации параметр #StartupPause = 30. В течение 30 сек после запуска, TCPFoss не будет пытаться устанавливать модемные соединения.

Программа не устанавливает модемное соединение.

В "Мой компьютер" откройте папку "Удаленный доступ к сети" и попытайтесь вручную установить соединение. Сообщение об ошибке подскажет причину отсутствия соединения.

Программа устанавливает модемное соединение, но обмена с абонентом нет.

Вручную установите модемное соединение с абонентом. Выполните команду:

Ping Addr

где Addr - IP адрес абонента, то же значение, что и у Addr в параметре #Host

При нормальном канале связи вы должны получить ответ:

ping 195.230.140.69

Pinging 195.230.140.69 with 32 bytes of data:

Reply from 195.230.140.69: bytes=32 time=1793ms TTL=61

Reply from 195.230.140.69: bytes=32 time=1257ms TTL=61

Reply from 195.230.140.69: bytes=32 time=1993ms TTL=61

Reply from 195.230.140.69: bytes=32 time=2006ms TTL=61

Отметьте, что время получения эха time>10ms, что говорит о том, что данные передавались и принимались через модем. В этом случае сверьте номера портов (см. параметр #Port) у Вас и у Вашего абонента, они должны быть одинаковыми.

Если time<10ms, то, скорее всего при создании соединения для подключения к абоненту в качестве IP адреса Вы задали не свой адрес, выданный Вам администратором абонента, а адрес абонента (см. раздел "Настройка Windows 95". Cоздание соединения дляподключениякабоненту, п.11 и раздел "Настройка Windows NT", Создание соединения для подключения к абоненту, п.4).

Следующий вариант работы ping:

ping 200.0.0.4

Pinging 200.0.0.4 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Если при выполнении команды ping Вы видите, что идет передача через модем, то в этом случае проблемы с настройкой у Вашего абонента. Скорее всего, Addr принадлежит не компьютеру с Ras сервером и этот компьютер не знает как вернуть ответ. Проблему можно решить настройкой протокола TCP/IP на компьютере абонента. Необходимо ввести адрес Шлюза, задав его равным адресу компьютера с Ras сервером ("Панель управления", "Сеть", "TCP/IP", "Свойства", "Шлюз" для Windows 95 или "Control Panel", "Network", "Protocols", "TCP/IP Protocol", "Properties", "Default Gateway" для Windows NT). Другой причиной может быть, что адреса Ras сервера и компьютера абонента находятся в разных подсетях.

Другими утилитами, с помощью которых можно выяснить причины отсутствия обмена являются tracert, route, telnet, winipcfg(только для Windows 95), dial-up networking monitor(только Windows NT).

Программа аварийно завершается. Windows 95 при этом выводит окно с сообщением об аварийном завершении и содержимое регистров и стека, Windows NT выводит сообщение и создает в системной папке файл drwtsn32.log с более подробной информацией об ошибке.

Сообщите об этой ситуации разработчику письмом по адресу S.Mamontov@foss.kharkov.ua. К письму присоедините файл drwtsn32.log или содержимое окна об аварийном завершении и файл конфигурации. В письме сообщите номер версии программы, в какой ситуации возникает ошибка, на каком сервере находились почтовые ящики. С разработчиком (Мамонтов Сергей Викторович) можно также связаться по телефонам (057) 7-195-194, 7-141-228.